reed broke, hit pickup, then spark, blown amp?

Tech Questions regarded the Wurlitzer Electric Piano

reed broke, hit pickup, then spark, blown amp?

Postby rayjefferson on Fri Jan 28, 2011 3:33 pm

i was tuning my 140b, and one of the reeds broke and touched the pickup followed by a loud pop, and spark where it hit. now there is a loud static in the speaker that is controlled by the volume pot, as well as the signal volume being lower. also when i unplug the pickup wire from the amp, the hissing/static is still there. i cleaned all of the pickup and checked for debris anywhere else that could make noise. is there anything i can do or is my amplifier toast?
rayjefferson
 
Posts: 1
Joined: Thu Jan 27, 2011 6:24 pm

Re: reed broke, hit pickup, then spark, blown amp?

Postby elilief on Wed Mar 09, 2011 11:28 pm

I would like to know about this too! I did the LED mod (new vintage vibe wiring harness, and I put in the jumper in the amp). I had my 140B working, playing great, but I hit a high note against the reed bar. Then a loud pop, than no sound! So I replaced the speaker, and when I turned it on, the 15K resistor caught fire! When I touched the volume pot I was shocked. :o help would be appreciated.

I did find this thread though:

I haven't tested this yet, but this looks like it could be the answer.

Eli
elilief
 
Posts: 9
Joined: Mon Oct 18, 2010 11:36 pm
---------



Return to Wurlitzer Electric Pianos

Who is online

Users browsing this forum: No registered users and 0 guests

cron